[비주얼 스튜디오 코드(Visual Studio Code)] 설치

에디터/비주얼 스튜디오 코드(Visual Studio Code) 2017.09.11 11:26

Vue js를 공부하려 하는데

많이 쓰이는 에디터로 이 비주얼 스튜디오 코드를 추천하는거 같습니다.

이 에디터는 Vue js 전용이 아닙니다. 퍼블리셔, 프론트엔드개발자 모두 사용할 수 있으며, 본인 입맞에 맞게 확장 기능을 늘려 주시면 됩니다.

이 에디터는 '무료' 이며 또 한글 메뉴라서 에디트 플러스 등을 사용해 보신 분이라면 익숙하게 사용할 수 있을듯 합니다.

저는 간단한 사용법과 추천 패키지 등을 소개해 드릴려고 합니다.



설치

URL : https://code.visualstudio.com/

어려운거 없이 그냥 구글 에서 비주얼 스튜디오 코드 를 검색하시거나

위의 URL 을 누르면 비주얼 스튜디오 코드 홈페이지가 뜹니다.

(비주얼 스튜디오 와 비주얼 스튜디오 코드는 다릅니다.)


맥 이라면 아마  Download for Mac  으로 버튼이 바뀌여서 나올꺼 갑습니다.

또는 우측의 화살표를 클릭해서 본인에게 맞는 OS를 선택해 설치를 진행하시면 됩니다.

추가적으로 함께 깔리는 거 없으니까 다운로드 받고 Next 또는 다음 버튼을 계속 눌러 주시기만 하시면 설치가 완료 됩니다.






설치 완료 후에 이런 화면이 뜨면 정상적으로 설치가 된겁니다.

 

댓글 7

  • 안유진 (2017.10.21 22:21 신고)

    print함수로 출력을 하면 "code language not supported or defined"라는 오류가 뜨는데요 뭐가 문제일까요?

    • 회복맨 (2017.10.21 23:17 신고)

      패키지 설치가필요합니다.
      VS code에는 PHP 언어는 기본 설치되어 있지 않기때문에 PHP언어 패키지를 검색해서 설치하시면 사용 가능할듯 합니다.

  • 안유진 (2017.10.22 12:25 신고)

    감사합니다~!

  • 씨언어매니아 (2017.12.18 06:40 신고)

    code language not supported or defined
    저도 이게 뜨는데 printf("Hello world\n");

    이렇게 작성하니까 오류가 뜨더라구요 PHP랑 씨는 전혀 별개아닌가요? C/C++랑 PHP랑은 전혀 별개로 알고있는데 PHP언어패키지 설치가 왜 필요한지 모르겠습니다 ㅠㅠ

    • 회복맨 (2017.12.18 07:39 신고)

      씨언어 패키지가 필요합니다.
      VS code는 씨언어 패키지가 기본으로 설치되어 있지 않기 때문에 씨언어 패키지를 설치하셔야 합니다.
      위에 댓글에서 PHP패키지를 '검색'해서 설치했듯이 씨언어 패키지 또한 별도로 '검색' 하셔야 합니다.

      패키지 설치 방법은 우측 메뉴 중 비주얼 스튜디오 코드 중 이 글을 제외한 다른글을 살펴 보시기 바랍니다.
      또한 비주얼 스튜디오 코드에서 씨언어를 지원하지 않을 시엔 그냥 지원되는 다른 IDE를 설치하시기 바랍니다

  • 루시집사 (2018.06.01 11:29 신고)

    안녕하세요
    vscode 검색 하다가 들어 왔는데
    참고할 자료가 많이 있네요
    감사합니다~

    • 회복맨 (2018.06.01 14:00 신고)

      방문해 주셔서 감사합니다. ^^
      닉네임이 익숙하네요 ㅎㅎㅋ